Once again

Once again an update to the firefox beta program has the potential to break Natwest/RBS online banking. For some inexplicable reason they detect what browser you are using and then make the decision for you whether it’s going to work or not regardless of if the browser you are using will work.

Fortunately, as I’ve previously posted HERE there is a way to solve the problem and fool natwest into thinking you are using a compatible browser.

The new problem is that mozilla have just reclassified the beta release from firefox 3.1 to firefox 3.5. The previous fix involved deleting the beta string from the user agent in about:config leaving Firefox/3.1 or Firefox/3.5 as the user agent. The new problem is that natwest don’t acknowledge the existence of firefox 3.5.

So for the meantime follow the steps in my previous fix making sure the identifier is Firefox/3.1 as before. Least until Natwest catch up or even better remove the stupid browser detection routine

Join the conversation

1 Comment

Leave a comment

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

By continuing to use the site, you agree to the use of cookies. more information

This site uses cookies. As does pretty much every single other website on the internet because without cookies the Internet doesn't work!. Sadly the EU have passed a stupid law which requires me to harass new visitors with a stupid pop up asking if it is ok for the site to use something which makes much of the internet work! The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible and to make this site work properly! If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this. Once you have accepted cookies you should not see this pop up again for 9999 months. Unless you use a different browser. Or a different device. See it's a stupid law isn't it! Normally I would advocate adding pop ups like this one into an ad blocker or some other kind of content blocker but please don't do that. This site is expensive to run and I need the ad revenue! Oh and if you'd like more information on the cookies this site uses check out the privacy policy link below. And for more of my thoughts on this stupid law check out the about me page!

Close